Wine团队宣布了新的开发版本Wine 6.4,新特性和各种bug修复。

Wine 6.4增加了DTLS协议支持。数据报传输层安全(DTLS)是一种设计用于保护UDP上的数据的协议,用于通信的应用程序,如媒体流、VOIP和在线游戏。

该版本的其他变化包括:

  • DirectWrite中的Fontset支持。
  • 用于编辑访问控制项的对话框。
  • 对一些常见控件的主题支持。
  • 支持韩国万成编码。

有各种各样的Windows应用程序的错误修复,包括《RTG Bills 2.x》、《Acrobat Reader XI》、《Soldiers of Anarchy》、《巫师3》等等。

如何在Ubuntu中安装Wine 6.4:

Ubuntu 18.04、Ubuntu 20.04和Ubuntu 20.10的包也已发布。

按下键盘上的Ctrl+Alt+T,或在系统应用程序菜单中搜索“terminal”,打开终端,依次运行以下步骤。

通过以下命令安装Wine Development版本将替换最新的稳定Wine发布包(如果已安装)。

1.)运行命令以启用32位体系结构(如果没有):

linuxmi@linuxmi:~/www.linuxmi.com$ sudo dpkg –add-architecture i386

询问时输入用户密码(无星号反馈),然后按Enter继续。

2.)通过运行以下命令来安装存储库密钥:

linuxmi@linuxmi:~/www.linuxmi.com$ wget -O – https://dl.winehq.org/wine-builds/winehq.key | sudo apt-key add –

3.)通过以下命令添加酒库:

linuxmi@linuxmi:~/www.linuxmi.com$ sudo apt-add-repository ‘deb https://dl.winehq.org/wine-builds/ubuntu/ focal main’

重要说明:在此命令中,您必须将focus替换为:

  • focal 适用于Ubuntu 20.04,Linux Mint 20.x
  • groovy 适用于Ubuntu 20.10
  • bionic 适用于Ubuntu 18.04和Linux Mint 19.x

不知道您的系统版本吗?在终端中运行lsb_release -a命令以检出。

4.)仅对于Ubuntu 18.04和Linux Mint 19.x,需要通过运行以下命令从第三方存储库安装libfaudio0库:

linuxmi@linuxmi:~/www.linuxmi.com$ sudo add-apt-repository ppa:cybermax-dexter/sdl2-backport

5.)最后通过命令安装Wine 6.4:

linuxmi@linuxmi:~/www.linuxmi.com$ sudo apt update && sudo apt install –install-recommends winehq-devel

如果遇到未满足的依赖关系问题,请尝试使用aptitude命令:

linuxmi@linuxmi:~/www.linuxmi.com$ sudo apt install aptitude && sudo aptitude install winehq-devel

卸载Wine:

您可以通过启动“软件和更新”实用程序并导航到“其他软件”选项卡来删除PPA。

要删除Wine 6.4,请在终端中运行命令:

linuxmi@linuxmi:~/www.linuxmi.com$ sudo apt remove –auto-remove winehq-devel

发表评论