对于那些不喜欢 Flatpak 包的人,本文介绍的是如何在 Ubuntu 20.04 LTS 中从 PPA 安装 GIMP 2.99.6 的教程。

受欢迎的 GIMP 图像编辑器正在开发下一个主要的 3.0 版本。 出于测试目的,GIMP 2.99.6 作为最新的开发版本发布。 它通过 Flatpak 包提供官方 Linux 包。 但是,有些用户不喜欢它,因为 Flatpak 是一种通用的包格式,需要单独的守护程序才能在沙箱中运行。

在 Ubuntu 20.04 中从 PPA 安装 GIMP 3.0 Dev:

对于 Ubuntu 20.04 和衍生版本,例如 Linux Mint 20 和 Zorin OS 16,非官方 PPA 包含用于 GIMP 3.0 Dev 版本的经典 .deb 包。

注意:PPA 中的包不稳定。 它可能有错误并且仅用于测试目的。 从这个 PPA 安装 GIMP 将覆盖 2.10 稳定版本,不要在生产机器上安装它。

1、添加 PPA。

按键盘上的 Ctrl+Alt+T 打开终端,如果您使用的是 Linux Mint 或 ZorinOS,则从开始菜单搜索并打开终端。

当终端打开时,复制并粘贴下面的命令并点击运行以添加 PPA:

linuxmi@linuxmi:~/www.linuxmi.com$ sudo add-apt-repository ppa:mati75/gimp30

键入您的密码,因为 sudo 命令需要用户身份验证,然后按 Enter 继续。

2、更新包缓存

从 Ubuntu 20.04 开始,它会在添加 Ubuntu PPA 时自动更新系统包缓存,但是,Linux Mint 20 不会。 因此,您可能需要在终端中手动运行命令来更新缓存:

linuxmi@linuxmi:~/www.linuxmi.com$ sudo apt update

3、安装/升级到 GIMP 3.0 Dev

最后,您可以打开软件更新程序(更新管理器)来安装或升级 GIMP 包,或者在终端中运行命令:

linuxmi@linuxmi:~/www.linuxmi.com$ sudo apt install gimp gegl

恢复到 GIMP 2.10 稳定版:

如果没有添加其他相关 PPA,可以将图像编辑器降级回 2.10 稳定版本,2.10.18。

只需打开终端并运行下面的命令来安装 ppa-purge 包,然后清除 Ubuntu PPA 这将删除它以及降级已安装的包:

linuxmi@linuxmi:~/www.linuxmi.com$ sudo apt install ppa-purge && sudo ppa-purge ppa:mati75/gimp30

就这样。

发表评论